I have created the approval workflow in sharepoint site but the workflow was not getting started and I got the following Error message in the Event viewer.

" Application Event:

Event Type:        Error
Event Source:        Windows SharePoint Services 3
Event Category:        General
Event ID:        6875
Date:                2/10/2011
Time:                4:36:25 PM
User:                N/A
Computer:        DJ
Description:
Error loading and running event receiver Microsoft.SharePoint.Workflow.SPWorkflowAutostartEventReceiver in Microsoft.SharePoint, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c. Additional information is below.

: The Web application at http://test/general/vacations/peabody could not be found. Verify that you have typed the URL correctly. If the URL should be serving existing content, the system administrator may need to add a new request URL mapping to the intended application.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp."



RESOLUTION:
                        I Found the cause for my case that we have changed default zone url from http://test/ to http://iotap.com/ in the Central Admin. So the workflow not able to recognize the host name URL.  So I have added the host header in the IIS(added host header value of  aurramu.blogspot.com in IIS), Host name in the Host file and Disable the Loop Back check on the sharepoint. Now the workflow is working very well

To Download our Sharepoint Skins and Webparts,visit Sharepoint Downloads page