if  the user profiles is not updated after you changed users property on the SSP and you get the following error

log in your SharePoint server 2007

then follow the following solutions steps

1. One of Microsoft’s best practices is to make sure that the application pool account for your SSP and your service account for the SSP are the same account.

2. Make sure to add this account to the backup operator’s local group on all your MOSS servers.

3. If you are using Kerberos authentication for your web applications make sure you set your service name principle account for you ssp on you MOSS application server. In order to complete this operation you must install Window support tools from your Windows server installation files under support>>tools>>supporttools.msi. Once you have installed the support tools go to start>>All programs>> Windows support tools>> command prompt.
setspn.exe –A HTTP/name_of_ssp_address domain\appication
Assume your site address is ssp, your domain is sharePoint, and your application pool account is svc_ssp. Run these commands
setspn.exe –A HTTP/ssp SharePoint\svc_ssp (Run this Command)
setspn.exe –A HTTP/ssp.sharepoint.com SharePoint\svc_ssp (Run this command)
If you are using Kerberos authentication on any of your web applications you must run these commands for the web applications to function properly including your central administration site.

4. Check your system event logs on your MOSS server for any DCOM errors.  You will notice your DCOM errors are associated with your application pool accounts.  Add these acounts to the IIS WAMREG admin service.  Make sure the accounts have local launch, remote launch, local activation, and remote activation.

5. Next stop your Office SharePoint Server Search through central administation>> operations>> Services on Server.

6. Then go to central administration>> operations>> service accounts.  Click on web application pool.  Then under web service choose Windows SharePoint Service Web application.  Next under application pool, choose your Shared Service Provider application pool account.  Under configurable you will notice that it populated your application pool account.  Now re-enter your password and click ok.

7. Login into all your MOSS servers and run iisreset /noforce.

8. Go back to central administation>> operations>> Services on Server and restart your Office Server Search.

9. Then go to central administation>>Application Management>> Manage this Farm's Shared Services.  click the drop down on the default SSP and click edit properties.  In the SSP service credentials enter username and password.  In the index server catagory select your index server and then click ok. Make sure you wait about 5 minutes.

i hope this should work.